Каталог

Помощь

Корзина

Автоматизированная информационная система Сервисный центр ООО Софт Мастер

Оригинальный документ?

Аннотация

 

В выпускной квалификационной работе на тему «Автоматизированная информационная система Сервисный центр ООО «Софт Мастер» реализован механизм автоматизации процесса приема и ремонта компьютерной техники для сервисных центров, а также формирование специализированной и управленческой отчетности. Основным инструментом автоматизации является «1С: Предприятие 7.7» с использованием конфигурации «1С: Бухгалтерский учет 7.7» редакция 4.5.

Система разработана для повышения эффективности, скорости обработки и прохождения потока информации внутри сервисного центра.

Правильная организация процесса приема компьютерной техники в ремонт позволяет оптимизировать использование оборотных средств предприятия и автоматизировать рутинную работу сотрудников.

Эффект от внедрения данной системы достигается за счет снижения трудоемкости выполнения работы сотрудниками и повышения качества деятельности сервисного центра.

 

Оглавление

 

Введение5

Глава 1. Автоматизация бизнес-процесса7

1.1. Анализ объекта автоматизации8

1.2. История автоматизации документооборота9

1.3. Обзор ранее выполненных работ на указанную тему10

1.4. Функциональный анализ работы СЦ по стандарту IDEF012

Глава 2. постановка задачи15

2.1. содержательная постановка задачи15

2.2. формальная постановка задачи16

Глава 3. Описание средств программирования17

3.1. Выбор типовой конфигурации23

3.2. Язык 1С24

Глава 4. реализация проекта25

4.1. Алгоритм автоматизации сервисного центра25

4.2. Интерфейсная часть26

4.3. структура данных35

4.4. возможности системы36

4.5. требования к ао и по39

4.6. Результаты автоматизации сервисного центра40

Заключение41

Список использованных источников43

Приложение 144

Приложение 248


Введение

 

Для эффективной работы сервисного центра необходима специализированная информационная система. Передо мной была поставлена задача автоматизировать работу сервисного центра от приема заявок на ремонт техники до формирования специализированных отчетов. Эти и другие факторы определили актуальность данной работы.

Подсистема обеспечивает, сотрудников сервисного центра, оперативной информацией о наличии соответствующих комплектующих на складе, о занятости мастеров. Эта информация необходима для правильного принятия решений о приеме техники в ремонт.

Автоматизировать работу сервисного центра, было решено с помощью 1С [1], поскольку 1С – это  система программ, которая предназначена для решения широкого спектра задач автоматизации учета и управления, стоящих перед динамично развивающимися современными предприятиями.  1С имеет единую технологическую платформу, которая позволяет не только модифицировать существующие конфигурации, но и создавать собственные «с нуля». Программные продукты системы «1С: Предприятие» содержат разнообразные средства для связи с другими программами и аппаратными средствами, что обуславливает их открытость. Эта система  не ориентирована на организацию с определенным видом деятельности. В настоящее время систему 1С используют в своей работе множество предприятий различной сферы деятельности, формы правовой организации, а так же с различным размером: будто предприятие крупное с численностью от 500 человек и выше или малое с численностью до 100 человек.

Данная задача является наиболее востребованной и актуальной во многих организациях ведущих предпринимательскую деятельность, направленную на оказание услуг сторонним организациям и физическим лицам. В данном случае автоматизации работы сервисного центра рассматривается на примере небольшой частной фирмы, которой требуется своя внутренняя система принятия техники в ремонт, формирования специализированной и управленческой отчетности, а также начисления заработной платы сотрудникам по их выполненным работам, проделанным для заказчика.

 

Глава 1. Автоматизация бизнес-процесса

 

Во время  выполнения функций управления или любого бизнес-процесса на предприятии, будь то в сфере производства или услуг, успешная деятельность будет зависеть непосредственно от организации сбора, обработки, маршрутизации и распространения информации.

Мониторинг статуса отдельных пунктов бизнес-процесса производят менеджеры, извлекая папки и просматривая написанные от руки аннотации.

Эта методика имеет ряд недостатков, основные из которых заключаются в том, что при такой организации информация часто теряется, возникают непредвиденные задержки на пути прохождения документов, трудно отследить состояние работы в определенный момент времени, поэтому возникла проблема автоматизации работы сервисного центра ООО «Софт Мастер».

 


1.1. Анализ объекта автоматизации

 

Объектом автоматизации выступил бизнес-процесс, небольшой частной фирмы ООО «Софт Мастер». Численность работников фирмы насчитывает пятнадцать человек, из них четверо являются обслуживающим персоналом (бухгалтер, 2 менеджера, диспетчер), директор и десять человек – это специалисты в области информационных технологий (программисты, системотехники и т.д.). Клиентская база данных насчитывает более двухсот записей, из них на постоянном обслуживании находится около 150 организаций. Кроме того организация предоставляет свои услуги физическим лицам как на территории заказчика так и в стационарных условиях. Схема работы с клиентами представлена на рисунке 1.

Схема работы сервисного центра

Рис 1. Схема работы сервисного центра


1.2. История автоматизации документооборота

 

Конец 60-ых и начало 70-ых годов характеризовалось использованием ЭВМ для автоматизации в основном процедуры контроля исполнения документов, заполнения регистрационных карточек и ведения электронной картотеки.

Позже в конце 70-ых и в начале 80-ых годов в таких системах стали применять электронную почту с редактором документов, позволившим создавать и отправлять по электронной почте документы.

Середина 80-ых годов отмечена появлением систем, автоматизирующих хранение электронных документов, которые гораздо более доступны и удобны в хранении, редактировании и использовании.


1.3. Обзор ранее выполненных работ на указанную тему

 

На протяжении трех преддипломных практик я постепенно приближался к решению основной задачи: автоматизация работы сервисного центра.

Первоначально темой преддипломной практики была «Оказание ИТ - услуг».  В этой работе была автоматизирована подсистема приема заявок от клиента. Затем был реализован механизм регистрации выполненных работ по фамилии сотрудника, наименованию заказчика и виду выполненной работы. На основании выполненных работ формировался отчет о выполненных программистом работах (в часах за месяц). А также была встроена подсистема прихода/расхода денежных средств. Система формировала отчет о движении денежных средств (учет поступления денежных средств, выплата заработной платы). На последней практике моей задачей стояло организация управленческого учета на предприятии. Со стороны руководства предприятия, на котором Я работаю, мне было предложено реализовать управленческий учет заработной платы в нашей фирме.

Решаемая задача относится к области автоматизации бухгалтерского учета и начисления заработной платы на предприятии, которое использует свои независимые правила и механизмы при выплате вознаграждения сотруднику за выполненные работы. Данная задача является наиболее востребованной и актуальной во многих организациях ведущих предпринимательскую деятельность, направленную на оказание услуг сторонним организациям и предприятиям. В данном случае автоматизации начисления заработной платы рассматривается на примере небольшой частной фирмы, которой требуется своя внутренняя система начисления заработной платы сотрудникам по их выполненным работам, проделанным для заказчика.

Основными целями работы над практиками являлись:

1. Реализация механизма регистрации выполненных работ и формировании необходимых отчетов, информирующих о состоянии предприятия, о загрузке программистов, о движении денежных средств. 

Реализация осуществляется на платформе «1С: Предприятие 7.7» с использованием встроенного языка программирования. Данный механизм демонстрирует процесс введения первичной информации о выполненных работах, на основании которых начисляется заработная плата сотрудникам организации. Программа должна регистрировать в журнале запись о выполненных работах по конкретному сотруднику, по наименованию заказчика и по виду выполненных работ, должна регистрировать операции с кассой (приходный и расходный кассовые ордера).

2. Освоить объектно-ориентированное программирование на встроенном языке платформы «1С: Предприятие 7.7». Научиться разбивать одну большую задачу (тему дипломной работы) на подзадачи (темы преддипломной практики), которые в последствии выльются в полноценный реализованный и востребованный дипломный проект. Получить навыки в решении сложных задач при помощи объектов.


1.4. Функциональный анализ работы СЦ по стандарту IDEF0

 

В конце 90-ых годов, когда на рынке в должной мере появилась конкуренция и рентабельность деятельности предприятий стала резко падать, руководители ощутили огромные сложности при попытках оптимизировать затраты, чтобы деятельность оставалась одновременно прибыльной и конкурентоспособной. Как раз в этот момент совершенно четко проявилась необходимость иметь перед своими глазами модель деятельности предприятия, которая отражала бы все механизмы и принципы взаимосвязи различных подсистем в рамках одного бизнеса. 

Само понятие «моделирование бизнес-процессов» пришло в быт с появлением сложных программных продуктов, предназначенных для автоматизации управления предприятием.

Процесс автоматизации деятельности предприятия включает этап описания и проектирования бизнес-процесса. Моделирование бизнес-процесса позволяет проанализировать, как организована деятельность предприятия на каждом отдельно взятом рабочем месте. Функциональная модель позволяет четко определить распределение ресурсов между операциями делового процесса, что дает возможность эффективно оценить используемы ресурсы, определить, сколько сотрудников необходимо привлечь для работы и какие функциональные обязанности эти сотрудники должны выполнять.

Наиболее известной и распространенной методикой является методология структурного анализа SADT (Structured Analysis and Design Technique).

Концепция SADT возникла в конце 60-ых годов в ходе революции, вызванной структурным программированием. В то время специалисты, традиционно занимавшиеся созданием крупномасштабных систем, стали осознавать необходимость большей упорядоченности.

На основе этой методологии был принят стандарт моделирования бизнес-процессов IDEF0 (Integration DEFinition 0) [9].

Методология моделирования IDEF0 предназначена для анализа всей системы как множества взаимосвязанных, взаимодействующих функции.

Ориентация исключительно на анализ функций позволяет рассматривать функции независимо от объектов, которые их выполняют. Функциональный подход позволяет четко определить проблемы анализа и проектирования от проблем реализации. Описание системы по правилам IDEF0 имеет четкую структуру. IDEF0 – модель представляет собой набор иерархически упорядоченных диаграмм. 

Каждая диаграмма описывает определенную функцию и состоит из нескольких взаимодействующих и взаимосвязанных подфункций, каждая из которых в свою очередь может быть описана диаграммой.

Разработка моделей IDEF0 требует соблюдения ряда строгих формальных правил, обеспечивающих преимущества методологии в отношении однозначности, точности и целостности сложных многоуровневых моделей.

Схема IDEF0 позволяет наглядно структурировать процессы организации и графически отобразить взаимодействие между этими процессами [10].

В IDEF0 реализованы три базовых принципа моделирования процессов:

1. Принцип функциональной декомпозиции представляет собой способ моделирования типовой ситуации, когда любое действие, операция, функция могут быть разбиты (декомпозированы) на более простые действия, операции, функции. Другими словами, сложная бизнес-функция может быть представлена в виде совокупности элементарных функций. Представляя функции графически, в виде блоков, можно как бы заглянуть внутрь блока и детально рассмотреть его структуру и состав.

2. Принцип ограничения сложности. При работе с IDEF0 диаграммами существенным является условие их разборчивости и удобной читаемости. Суть принципа ограничения сложности состоит в том, что количество блоков на диаграмме не должно не менее двух и не более шести. Практика показывает, что соблюдение этого принципа приводит к тому, что функциональные процессы, представленные в виде IDEF0 модели, хорошо структурированы, понятны и легко поддаются анализу.

3. Принцип контекстной диаграммы. Моделирование делового процесса начинается с процесса построения контекстной диаграммы. На этой диаграмме отображается только один блок – главная бизнес-функция моделируемой системы. Главная бизнес-функция системы – это «миссия» системы, ее значение в окружающем мире.

Модель бизнес-процесса «сервисный центр» представлена в приложении 1.


Глава 2. Постановка задачи

 

2.1. Содержательная постановка решаемой задачи:

 

Цель: Разработать алгоритм автоматизации работы сервисного центра, изменив и доработав имеющиеся модули в системе «1С: Бухгалтерский учет 7.7» редакция 4.5 в соответствии с заявленными требованиями.

 

Задачи:

1. Автоматизировать процесс приема техники в ремонт.

2. Автоматизировать рабочее место диспетчера.

3. Организовать анализ деятельности работы сервисного центра для руководителя, путем анализа формируемых отчетов.


2.2. Формальная постановка решаемой задачи:

 

Стадии разработки:

1. Подготовить структуру данных в «1С: Бухгалтерский учет 4.5».

a. Разработка интерфейса пользователя

b. Размещения каталога запасных частей и оборудования с фотографиями.

c. Размещение информации о количестве товара на складе.

2. Разработать алгоритм процесса принятия техники в ремонт.

a. Оформление заявок клиентов

b. Выполнение заявок клиентов на территории клиента либо в стационарных условиях.

3. Реализация созданного алгоритма.

4. Создать необходимые дополнительные документы и их печатные формы.

a. Разработка документа «Заявка».

b. Разработка документа «Квитанция».

c. Разработка документа «Наряд-заказ».

5. Реализовать формирование специализированной и управленческой отчетности.

a. Разработка отчета «Выполненные работы»

b. Разработка отчета «Остатки ТМЦ»

c. Разработка обработки «Расчет заработной платы сотрудникам»

 

Глава 3. Описание средств программирования

 

В качестве средства программирования для автоматизации сервисного центра была выбрана система "1С:Предприятие". Это специализированная объектно-ориентированная система управления базами данных (СУБД), предназначенная для автоматизации деятельности предприятия.

С одной стороны, система 1С: Предприятие - это мощный инструмент автоматизации и анализа финансово-экономической деятельности предприятия. С другой стороны - это сложный программный продукт, для эффективного применения которого зачастую необходимы познания, относящиеся не только к области бухгалтерского учета, но и к чистому программированию.

Система "1С:Предприятие" предназначена для автоматизации управления и учета на предприятиях различных отраслей, видов деятельности и типов финансирования. Она включает в себя решения для производственных предприятий (комплексное решение "1С:Управление производственным предприятием 8.0"), торговых предприятий, продукты для ведения бухгалтерского учета ("1С:Бухгалтерия"), учета в бюджетных организациях, расчета зарплаты и управления кадрами, разнообразные отраслевые и специализированные решения, разработанные как самой фирмой "1С", так и ее партнерами.

В настоящее время существует очень много программ подобного рода. Эта система воплощает самые передовые технологии баз данных, а именно: объектно-ориентированный подход к разработке программ, который ускоряет и упрощает разработку в десятки раз. Плюсом является то, что 1С:Предприятие наиболее распространена в пределах России и СНГ. Эта система предоставляет широкий набор объектов, на основе которых и создаются все прикладные решения. К ним относятся справочники, документы, регистры и т.д. А также система имеет встроенный язык программирования, механизм запросов, различные визуальные редакторы и конструкторы.

Таким образом, решение об использовании системы «1С. Предприятие 7.7» было принято сразу, и оно обусловлено следующими факторами:

1. Распространенность системы программ «1С. Предприятие».

2. Открытость платформы, возможностью внесения изменений не дожидаясь действий со стороны разработчика.

3. Разнообразие существующих решений для различных задач.

4. Поддержка баз данных в формате DBF.

5. Наличие Web-интерфейса.

6. Возможность работы с внешними файлами: текстовыми, DBF.

7. Наличие встроенного языка.

8. Популярность. Система программ 1С является наиболее распространенной (до 60% всех организаций в России).

9. Единая технологическая платформа. Она является фундаментом для построения всех прикладных решений. Облегчает создание отдельных прикладных решений и обеспечивает их не высокую стоимость.

10. Автоматизация отдельных задач и комплексная автоматизация. Система программ «1С Предприятие» предоставляет возможность автоматизации как за счет внедрения отдельных прикладных решений, которые будут работать автономно или интегрироваться с использованием различных механизмов информационного обмена, так и за счет использования комплексных решений. Использование обособленных решений проще и эффективнее, если отдельные задачи автоматизации на предприятии мало пересекаются. Комплексные решения эффективнее при сильной увязке различных задач автоматизации и готовности предприятия к формированию единого информационного пространства. Разумеется на одном предприятии могут использоваться как комплексные решения так и обособленные программы.

11. Стандартные, специализированные и индивидуальные решения.

Система «1С. Предприятие 7.7» разработана фирмой «1С» в 1999 году. От остальных систем, существующих на рынке, выгодно отличается низкой начальной стоимостью и неограниченными возможностями изменения существующих и создания новых учетных конфигураций.

На сегодняшний день бесспорным лидером по продажам и количеству инсталляций являются программные продукты фирмы "1С". Более 2300 компаний в 430 городах России занимаются внедрением программ серии "1С". Не последнюю роль в этом успехе играет особая политика фрайчазинга, когда сама фирма "1С" занимается только разработкой программного обеспечения, а внедрением и "подгонкой" под конкретные нужды потребителей заняты местные специалисты.

Система поставляется как в однопользовательском, так и в сетевом вариантах, причем сетевой вариант может работать как с базами данных в DBF-формате, так и совместно с программой MS SQL 6.5 - 2000.

Кроме того, система предлагает широкие возможности по разграничению прав доступа пользователей к информации и определения прав. Каждое действие пользователей фиксируется в журнале, просмотр которого можно вести, в том числе, и по заданным заранее фильтрам.

Любая учетная система имеет как минимум четыре компонента:

· Систему хранения, поиска и редактирования условно-постоянной и нормативно-справочной информации, которая изменяется достаточно редко (справочники).

· Систему ввода и фиксации событий внешнего мира (документов, хозяйственных операций и др.), влияющих на состояние системы.

· Систему работы с динамической информацией (остатки).

· Генератор отчетов, позволяющий получать разнообразные отчеты как на основе динамических данных и истории их изменения, так и по справочной информации и истории событий.

И связаны они, как правило, таким образом, что при вводе событий на базе информации, хранящейся в справочниках, выполняется изменение динамической информации (остатков). Причем изменение остатков выполняется путем формирования набора элементарных операций (проводок или движений). В дальнейшем на основе информации, хранящейся в системе, пользователь получает разносторонние отчеты.

В «1С. Предприятие» все это есть, при этом есть даже три варианта хранения динамической информации: Планы счетов и проводки, используемые обычно для бухгалтерского учета, Регистры и движения, используемые обычно для оперативного учета и Журналы расчетов, используемых для различных сложных расчетов, например, расчета заработной платы. Поэтому использование 1С является естественным выбором, если требуется построить какую-нибудь учетную автоматизированную систему.

Отличительная особенность системы - возможность настройки и конфигурирования индивидуально, согласно требованиям и желаниям потребителя. Собственно система «1С. Предприятие» представляет собой совокупность механизмов, предназначенных для манипулирования различными типами объектов предметной области. Конкретный набор объектов: информационной структуры, массивов данных, алгоритмов обработки информации определяет конкретная конфигурация программы. Настроенная и сконфигурированная система «1С. Предприятие» выступает в качестве уже готового к использованию программного продукта, ориентированного на определенные типы предприятий и классы решаемых задач.

Встроенный язык системы «1С. Предприятие» предназначен для описания (на стадии разработки конфигурации) алгоритмов функционирования прикладной задачи.

Встроенный язык представляет собой предметно-ориентированный язык программирования, специально разработанный с учетом возможности его применения не только профессиональными программистами. В частности, все операторы языка имеют как русское, так и англоязычное написание, которые можно использовать одновременно в исходном тексте.

При своей относительной простоте язык обладает некоторыми объектно-ориентированными возможностями, например, правила доступа к атрибутам и методам специализированных типов данных (документам, справочникам и т.п.) подобны свойствам и методам объектов, используемых в других объектно-ориентированных языках. Однако специализированные типы данных не могут определяться средствами самого языка, а задаются в визуальном режиме конфигуратора.

Типизация переменных в языке не жесткая, т.е. тип переменой определяется ее значением. Переменные не обязательно объявлять в явном виде. Неявным определением переменной является ее первое упоминание в левой части оператора присваивания. Возможно также явное объявление переменных при помощи соответствующего оператора. Допускается применение массивов.

Формой в системе «1С. Предприятие» называется совокупность трех взаимосвязанных компонентов: экранного представления элемента данных, его печатного представления и алгоритма на внутреннем языке системы «1С. Предприятие», который связывает экранное и печатное представление (интерфейс, диалог). Алгоритм на внутреннем языке системы «1С. Предприятие» также называется модулем.

Метаданными («данными о данных») в системе «1С. Предприятие» называется совокупность объектов метаданных, настроенных на хранение и обработку информации о хозяйственной деятельности конкретного предприятия. Наряду с понятием метаданные, широко используется термин «структура метаданных». Данный термин более точно отражает суть метаданных, как сложной структуры взаимодействующих объектов метаданных. Фактически, структура метаданных является моделью предметной области.

Для создания форм объектов метаданных в системе «1С. Предприятие» используется комплексный редактор форм. Он позволяет редактировать все перечисленные компоненты визуального представления объекта метаданных, фактически является совокупностью трех редакторов: редактора диалогов, текстового и табличного редакторов.

Внешне редактор форм реализован в виде метафоры рабочей книги, каждый лист которой содержит один из компонентов визуального представления и может редактироваться соответствующим редактором.

 

3.1. Выбор типовой конфигурации

 

Основной особенностью системы 1С: Предприятие является её конфигурируемость. Система представляет собой совокупность механизмов, предназначенных для манипулирования различными типами объектов, структуры информационных массивов, алгоритмы обработки информации определяет конкретная конфигурация.

В качестве типовой конфигурации выбрана «1С Бухгалтерский учет» редакция 4.5.

Сделанный выбор обусловлен возможностью надстройки над данной конфигурацией обособленного решения, а также в ней есть все необходимое для связи бухгалтерского и управленческого учета.

Автоматизированный сервисный центр ООО «Софт Мастер» разработан как надстройка к типовой конфигурации бухгалтерского учета. Это было сделано для правильного ведения управленческого учета в рамках бухгалтерского и налогового учетов.


3.2. Язык 1С

 

Встроенный язык системы 1С Предприятие предназначен для описания (на стадии разработки конфигурации) алгоритмов функционирования прикладной задачи.

Язык 1С представляет собой предметно-ориентированный язык программирования, специально разработанный с учетом возможности его применения не только профессиональными программистами. В частности все операторы языка имеют как русское, так и англоязычное написание, которое можно использовать одновременно в одном исходном тексте программы.

При своей относительной простоте обладает некоторыми возможностями объектно-ориентированного программирования, например, правила доступа к атрибутам и методам специализированных типов данных (документы, справочники и т.д.) подобны свойствам и методам объектов, используемых в других объектно-ориентированных языках. Однако специализированные типы данных не могут определяться средствами самого языка, а задаются в визуальном режиме конфигуратора.

Типизация переменных в языке не жесткая, т.е. тип переменной определяется ее значением. Переменные не обязательно объявлять в явном виде.


Глава 4. Реализация проекта

4.1. Алгоритм автоматизации сервисного центра

Входными данными для реализации автоматизированного сервисного центра являются:

1. Заявка на ремонт, которая включает в себя наименование техники, дату принятия, ответственное лицо, информация о клиенте, вид работ, фамилия мастера, ориентировачная стоимость, желаемая дата выезда мастера.

2. Входные данные клиента: личная карточка, адрес, телефон, банковские реквизиты.

Для реализации задачи по автоматизации работы сервисного центра был разработан алгоритм:

1. Прием заявки (Call Centre).

2. Прием техники (Приемный пункт).

3. Регистрация заявок и квитанций.

4. Выбор сотрудника в соответствии с критериями.

5. Подтверждение выбора.

6. Выезд сотрудника к клиенту.

7. Принятие техники в производственный цех

8. Мониторинг исполнения заказов.

9. Информирование клиента о ходе ремонта.

10. Выдача техники клиенту.

Сам алгоритм представлен на схеме в приложении 1.

В результате анализа существующей конфигурации «1С: Бухгалтерский учет 4.5» была выявлена необходимость создания дополнительных справочников, документов, обработок и необходимость изменения существующих метаданных для реализации алгоритма в соответствии с заявленными требованиями.


4.2. Интерфейсная часть

 

1) Объекты типа Перечисление:

a) Перечисление «Статус гарантии» (гарантия, снято с гарантии, гарантия закончилась). Гарантия – техника подлежит бесплатному гарантийному ремонту; снято с гарантии – техника снята с гарантии в следствии обнаружения признаков не правильного использования оборудования; гарантия закончилась – период бесплатного гарантийного ремонта истек.

b) Перечисление «Вид номенклатурной позиции» (товар, зип). Товар – наименование номенклатурной позиции; зип – запасная часть.

c) Перечисление «Статус ремонта» (в ремонте, отремонтировано). В ремонте – техника находится у мастера на складе или производится ремонт; отремонтировано – техника готова для передачи клиенту.

d) Перечисление «Статус оборудования» (на складе, в резерве. продано). На складе – запасная часть присутствует на складе; в резерве – запасная часть присутствует на резервном складе; продано – оборудование реализовано заказчику.

2)  Объекты типа Справочники:

a) Справочник «Контрагенты» (см. рис. 2). В него добавлена закладка с дополнительной информацией (расчетные счета, дополнительные свойства), расчетные счета необходимы если клиент оплачивает услуги через банк.

 

Справочник «Контрагенты»

 

Рис. 2 Справочник «Контрагенты»

 

b)  Справочник «Виды обслуживаемых объектов» (см. рис. 3)  (наименование). Существует возможность печати списка видов обслуживаемого оборудования.

 

Справочник «Виды обслуживаемых объектов»

 

Рис. 3 Справочник «Виды обслуживаемых объектов»


c)  Справочник «Номенклатура» (см. рис. 4)  . Содержит список моделей обслуживаемой техники, а также список запчастей, используемых при ремонте.

 

Справочник «Номенклатура»

 

Рис. 4 Справочник «Номенклатура»

 

d) Справочник «Перечень оказываемых услуг» (см. рис. 5) . Содержит список услуг по ремонту оборудования, оказываемых организацией. Существует возможность печати списка перечня оказываемых услуг. 

Изображение 5

Справочник «Перечень оказываемых услуг»

Рис. 5 Справочник «Перечень оказываемых услуг»

e) Справочник «Состояния ремонта» (см. рис. 6). Содержит список возможных состояний, в которых может находиться оборудование при ремонте. Существует 3 типа состояний:

   начальное

   промежуточное

   конечное

 

Справочник «Состояния ремонта»  

 

Рис. 6 Справочник «Состояния ремонта»

 

3)  Объекты типа Документ.

a)  Документ «Заявка» (см. рис. 7). Предназначен для регистрации обращений клиентов. Фиксируется обратившийся клиент, модель, содержание заявки со слов клиента, желаемая дата выезда, указывается вид работ. Отслеживается текущее состояние заявки и вся история его изменения. На основании заявки можно сформировать документ Наряд-заказ. Заявки хранятся в журнале заявок, который содержит список заявок за определенный период времени. Для каждой заявки отображается текущее состояние заявки, Заказчик, модель оборудования и т.д. Существует возможность отбора заявок по: состоянию заявки, Заказчику, сотруднику.

 

Документ «Заявка»

 

Рис.7 Документ «Заявка»

 

 

b) Документ «Квитанция» (см. рис. 8). Служит для оформления приема техники в ремонт. Осуществляется выбор типа ремонта (платный, гарантийный, восстановительный), Заказчик (разовый клиент, постоянный), модель и серийный номер оборудования, комплектация и внешний вид, описание неисправности со слов клиента.

 

Документ «Квитанция»

 

Рис.8 Документ «Квитанция»

 

   c) Документ «Наряд-заказ» (см. рис. 9). Предназначен для отражения в учете операций по оказанию услуг (выполнению ремонтных работ) с возможностью списания запасных частей. Может быть введен на основании первичных документов, автоматическое формирование бухгалтерских документов, имеет настраиваемую печатную форму.

 

 

Документ «Наряд-заказ»

Рис. 9 Документ «Наряд-заказ»

 

4)   Объекты типа Отчет.

a) Отчет по заявкам (см. рис. 10). Специализированный отчет формирует информацию о поступивших и выполненных заявках в разрезе менеджеров, сотрудников (мастеров) и контрагентов (клиентов) с оборотом по состоянию.


Изображение 11

Отчет «Отчет по заявкам»

 

Рис. 10 Отчет «Отчет по заявкам»

 

b) Отчет по выполненным работам (см. рис. 11). Специализированный отчет формирует информацию о выполненных работах в разрезе сотрудников (мастеров), видов работ и контрагентов (клиентов) с оборотом по состоянию.

 

Изображение 13

Отчет «Отчет по выполненным работам»

 

Рис. 11 Отчет «Отчет по выполненным работам»


Листинги основных модулей программы представлены в приложении 2.

  


4.3. Структура данных

 

Структура данных автоматизированного сервисного центра представлена в виде иерархии и отображена рисунке 12.

 

Структура данных автоматизированного сервисного центра представлена в виде иерархии и отображена унке 12. 4.4. Возможности системы
4.4. Возможности системы

 

АИС Сервисный центр ООО «Софт Мастер» - это комплексное решение, предназначенное для автоматизации деятельности сервисных центров. Возможности конфигурации позволяют автоматизировать деятельность сервисного центра от момента приема техники до формирования отчетов.

Требования к системе:

1. Автоматизация процесса приема техники в ремонт

2. Формирование специализированной и управленческой отчетности

3. Система отслеживания состояния техники (в ремонте, отремонтировано)

4. Учет обслуживаемого оборудования

5. Учет заявок от клиентов

6. Учет нарядов для сотрудников

7. Учет ТМЦ

В системе реализованы следующие модули:

1. Пункт приема техники;

2. Диспетчерская служба (Call Centre);

3. Производственный процесс (сервис);

4. Склад запчастей и аксессуаров;

5. Формирование отчетов;

6. Управленческие отчеты.

Система предназначена для автоматизации пункта занимающегося приемом бракованной техники в цех. Клиентами компании могут быть как физические, так и юридические лица. Центральным документом подсистемы является документ «заказ – наряд», который служит для оформления операции приема бракованной техники в цех. Принципиальная схема документооборота, заложенная в подсистеме представлена на рисунке 1.

Документ заказ – наряд может вводиться на основании документа заявка оформленного в диспетчерской службе. Это бывает необходимо для техники, которую не удалось отремонтировать на территории клиента и требуется ее доставка в цех. Приемный пункт обладает собственным складом хранения, с которого по необходимости может быть организовано перемещение, как на общий склад аппаратов, так и на склад мастера.

Основные функциональные возможности системы:

1. Прием техники у контрагентов (физические и юридические лица)

2. Информирование клиента о ходе ремонта изделия

2.1. Информирование о текущем состоянии изделия (в ремонте, заказаны детали, отремонтировано, не гарантийный случай) - список состояний произвольный, задается на уровне справочников.

2.2. Контроль сроков нахождения техники в ремонте    

2.3.Текущее местонахождение техники (склад аппаратов с указанием ячейки, мастер)

3. Выдача техники клиенту

3.1. Формирование пакета документов (акты выполненных работ, накладных на возврат)

3.2. Выписка актов о замене (списании) аппаратов

Для удобства реализованы вспомогательные справочники: модели, типы ремонта, комплектность, внешний вид и другие.

Программа предназначена для автоматизации работы следующих участков:

 Учет обслуживаемого оборудования:

по видам объектов – количество видов не ограничено;

по моделям – для каждого вида объектов можно задать неограниченное число моделей,

по серийным номерам;

 Прием техники в ремонт:

оформление приема техники в ремонт - документ "Квитанция";

выбор типа ремонта (платный, гарантийный, восстановительный);

формирование управленческих отчётов.

 Учет договоров сервисного обслуживания:

заключение, пролонгация, дополнение, расторжение, приостановка;

список объектов, обслуживаемых по договору;

выбор типа цены обслуживания и периодичности выставления актов;

 Учет заявок от клиентов:

прием заявок от клиентов;

отслеживание состояния заявок (принята, передана сотруднику, выполнена, аннулирована) и контроль выполнения заявок по дате;

 Учет нарядов для сотрудников:

ввод нарядов на основании заявок;

отслеживание состояния наряда (выполнен / не выполнен);

ввод на основании первичных нарядов;

фиксация перечня произведенных работ;

фиксация использованных при ремонте деталей и материалов;

 Учёт ТМЦ:

полный перечень операций: поступление, выдача механикам, продажа, возврат неиспользованных запчастей,

учёт по серийным номерам;


4.5. Требования к АО и ПО

 

Технические требования к аппаратному обеспечению автоматизированного рабочего места определяются минимальными требованиями платформы 1С: Предприятие 7.7:

1. Частота процессора не ниже 400 МГц;

2. ОЗУ не менее 128 Мб;

3. Минимальный объем дискового пространства 500 Мб;

4. Наличие сетевой платы и принтера. 

Требованию к программному обеспечению  АРМ:

1. ОС семейства Windows’98/XP;

2. ПО «1С: Предприятие 7.7», Конфигурация «1С: Бухгалтерский учет 7.7» редакция 4.5;

Требование к серверу БД:

1. Частота процессора не ниже 1,5 ГГц;

2. Объем ОП не менее 512 Мб;

3. Минимальный объем дискового пространства 2 Гб;

4. Наличие сетевой платы;

5. ОС семейства Windows Server 2000-2003.


4.6. Результаты автоматизации сервисного центра

 

Результатом проделанной работы стала конфигурация, полностью удовлетворяющая заявленным требованиям. Она позволяет ввести в базу данных информацию о выполненных работах, путем заполнения соответствующего документа. Результат ввода документа регистрируется в журнале документов. На основании введенных документов можно сформировать специализированные и управленческие отчеты, отражающие информацию о заработной плате работников, загрузке сотрудников, количестве запасных частей и оборудования на складе,  а также позволяет контролировать движение денежных средств.

 

Заключение

 

В результате проделанной работы была разработана система, которая автоматизирует работу сервисного центра ООО «Софт Мастер» от приема компьютерной техники в ремонт до формирования специализированной и управленческой отчетности.

Внедрение системы повысило эффективность работы сервисного центра, скорость принятия решений, а также сократила расходы на ведение документации и оплату работы сотрудникам.

Кроме того в системе реализован управленческий учет, который тесно связан с бухгалтерским учетом и исключает возможность двойного ввода информации. В системе  реализован модуль расчета зарплаты сотрудникам на основании выполненных работ.

Система позволила:

1. ускорить обработку данных

2. повысить производительность труда сотрудников за счет прогрессивной системы оплаты труда

3. снизить количество ошибок в оформлении документов

4. увеличить скорость прохождения информации в организации

5. контролировать и управлять запасами

6. оптимизировать затраты организации

7. в целом повысить эффективность деятельности предприятия

 В данной работе была доработана типовая конфигурация

1. доработана структура данных

2. добавлены метаданные, формы, документы, справочники, перечисления, отчеты, обработки

3. реализован механизм приема техники в ремонт

В качестве развития созданной системы предполагается добавить блок метаданных, учитывающий опыт экспертов в данной области.


В результате выполненной работы в системе «1С:Предприятие 7.7 ПРОФ» была доработана конфигурации «1С Бухгалтерский учет 4.5». Необходимая структура данных: документы, справочники, отчеты, обработки, а также функции и процедуры к ним, с помощью которых реализован алгоритм автоматизации сервисного центра полностью удовлетворяют поставленной задаче.

 

Список использованных источников

 

1. Колпинский Н.Н. 1С:Предприятие. Практика программирования на платформе V7.

2. Филимонова Е.В. Практическая работа в 1С:Предприятие 7.7. Настройка, конфигурирование, программирование и эксплуатация. Учебное пособие. Изд. 2-е. доп. И перераб. – Ростов н/Д: изд-во «Феникс», 2004 – 416с.

3. Байдаков В., Борун А., Федоров Б. 1С: Предприятие 7.7. Описание встроенного языка (в двух частях). М., Фирма «1С», 1999 г.

4. Байдаков В., Нуралиев С., Шевченко А. Введение в конфигурирование 1С: Бухгалтерии 7.7. М., Фирма «1С», 2000 г.

5. Байдаков В., Борун А., Нуралиев С., Федоров Б., Филиппов В. 1С: Предприятие 7.7. Конфигурирование и администрирование (в двух частях). М., Фирма «1С», 1999 г.

6.  Методология функционального моделирования IDEF0. Руководящий документ. Издание официальное. Госстандарт России. Москва. (РД IDEF 0 - 2000).

7. Киевский С.В. Методология функционального моделирования. М., 2000.


Приложение 1

Контекстная диаграмма 

Контекстная диаграмма


Декомпозиция контекстной диаграммы

Декомпозиция контекстной диаграммы


Декомпозиция блока А1

Декомпозиция блока А1


Декомпозиция блока А2

Декомпозиция блока А2


Приложение 2

 

Листинг Документ.Квитанция

 

//***********************************************************************

//Выбор вида обслуживания

Процедура ПереключательВО()

                Если Гарантия = 1 Тогда

                              

                ИначеЕсли Гарантия = 2 Тогда

                              

                КонецЕсли;

КонецПроцедуры            

//*****************************************************************

//Выбор исполнителя

Процедура ПереключательИсп()

                Если ВыпТО = 1 Тогда

                               Форма.РемФирма.Видимость(0);

                               РемФирма = "";

                ИначеЕсли ВыпТО = 2 Тогда

                               Форма.РемФирма.Видимость(1);

                КонецЕсли;

КонецПроцедуры

//*******************************************************************

//Ввод на основании

Процедура ВводНаОсновании(ДокументОснование)

                ДокОсн = СоздатьОбъект("Документ");

                Если ДокОсн.ВыбратьПодчиненныеДокументы(,,ДокументОснование) <> 0 Тогда

                               СтатусВозврата(0);

                               Возврат;

                КонецЕсли;

                Если ДокументОснование.Проведен() = 0 Тогда

                               СтатусВозврата(0);

                               Возврат;

                КонецЕсли;

                ДокОснование = ДокументОснование;

                НомерДок = ДокументОснование.НомерДок;

                Клиент = ДокументОснование.Клиент;

                СерийныйНомер = ДокументОснование.СерийныйНомер;

                Артикул = ДокументОснование.Артикул;

                Причина = ДокументОснование.Причина;

                СрокИсп = ДокументОснование.СрокИсп;

                ДатаПриема = ДокументОснование.ДатаДок;

                ТипОбслуживания=ДокументОснование.ТипОбслуживания;

                Спр=СоздатьОбъект("Справочник.Оборудование");

                Если Спр.НайтиЭлемент(СерийныйНомер)=1 Тогда

                               Если ДобавитьМесяц(Спр.ДатаПрихода,Спр.СрокГарантии)<РабочаяДата() Тогда

                                               Спр.СтатусГарантии=Перечисление.СтатусыГарантии.ГарантияЗакончилась;                                                   

                                               Гарантия=2; // негарантийное обслуживание

                               Иначе// если случайно изменили, во время отката даты

                                               Спр.СтатусГарантии=Перечисление.СтатусыГарантии.Гарантия;                            

                                               Гарантия=1; // гарантийное обслуживание

                               КонецЕсли;

                               Спр.Записать();

                    СтатусГарантии=Спр.СтатусГарантии;

                Иначе

                               Предупреждение("Не найден серийный номер!");

                КонецЕсли;

                ВыпТО = 1;

 

                Автор=глАвтор;

КонецПроцедуры

//**************************************************************************

//Открытие бланка техническое обслуживание

Процедура ПриОткрытии()

    Если ПустоеЗначение(ДокОснование) = 1 Тогда

                               СтатусВозврата(0);

                               Возврат;

                КонецЕсли;

                ПереключательВО();

                ПереключательИсп();

                Если Проведен() = 1 Тогда

                               Форма.ТолькоПросмотр(1);

                    Форма.ИККвит.Видимость(1);

                               Форма.ИКВып.Видимость(0);

                Иначе   

                               Форма.ТолькоПросмотр(0);

                               Форма.ИККвит.Видимость(0);

                               Если (НазваниеИнтерфейса() = "Техник") ИЛИ (НазваниеИнтерфейса() = "Администратор") Тогда

                                               Форма.ИКВып.Видимость(1);

                               Иначе   

                                               Форма.ИКВып.Видимость(0);

                               КонецЕсли;        

                КонецЕсли;

                ПриЗаписиПерепроводить(0);

КонецПроцедуры

//

//Перечень Работ

Процедура ПоКнЗИП()

                Если Выбран() = 1 Тогда

                               ЗМ = СоздатьОбъект("Документ");

                               ЗМ.ВыбратьПодчиненныеДокументы(,,ТекущийДокумент());

                               Если ЗМ.ПолучитьДокумент() = 1 Тогда

                                               Если Проведен() = 0 Тогда

                                                               ОткрытьФорму(ЗМ.ТекущийДокумент(),,0);

                                                               Возврат;

                                               Иначе

                                                   ОткрытьФорму(ЗМ.ТекущийДокумент(),,1);

                                                               Возврат;

                                               КонецЕсли;        

                               Иначе

                                               ОткрытьФорму("Документ.ТОЗИП",Контекст,ТекущийДокумент());

                               КонецЕсли;

                Иначе

                               ФлагВ = Вопрос("Записать документ Выполнение техническое обслуживание в базу данных?",1,0);

                               Если ФлагВ = 1 Тогда    

                                               Записать();

                                               ОткрытьФорму("Документ.ТОЗИП",Контекст,ТекущийДокумент());

                               ИначеЕсли ФлагВ = 2 Тогда

                                               Возврат;

                               КонецЕсли;

                КонецЕсли;           

КонецПроцедуры

//

//Завершение ТО

Процедура ПоКнВыполнено()

                Если ПустоеЗначение(Неисправность) = 1 Тогда

                               Предупреждение("Не указана неисправность!");

                    Возврат;

                КонецЕсли;

                Если (ВыпТО = 2) И (ПустоеЗначение(РемФирма) = 1) Тогда

                               Предупреждение("Не выбрана обслуживающая фирма!");

                    Возврат;

                КонецЕсли;

                ДатаДок = ТекущаяДата();

                Записать();

                Провести();

                //

                Если Проведен() = 1 Тогда

                               Форма.ТолькоПросмотр(1);

                    Форма.ИККвит.Видимость(1);

                               Форма.ИКВып.Видимость(0);

                Иначе   

                               Форма.ТолькоПросмотр(0);

                               Форма.ИККвит.Видимость(0);

                               Форма.ИКВып.Видимость(1);

                КонецЕсли;

КонецПроцедуры            

//

//Возможность сохранения

Процедура ПоКнОк()

                Если Проведен() = 0 Тогда

                               Если (ВыпТО = 2) И (ПустоеЗначение(РемФирма) = 1) Тогда

                                               Предупреждение("Не выбрана обслуживающая фирма!");

                                   Возврат;

                               КонецЕсли;

                    ККР = СоздатьОбъект("Справочник.Оборудование");

                               Если ККР.НайтиЭлемент(СерийныйНомер) = 1 Тогда

                                               ККР.Клиент = Клиент;

                                               ККР.Записать();

                               Иначе

                                               Предупреждение("Оборудование с серийным номером "+СерийныйНомер+" не найдено!");

                                               Возврат;

                               КонецЕсли;

                               Записать();

                КонецЕсли;

                Форма.Закрыть(0);          

КонецПроцедуры

//

//*********************************************************

//

//Печать квитанции

Процедура ПоКнКвитанция()

                //Печать

                Таб = СоздатьОбъект("Таблица");

                Таб.ИсходнаяТаблица("Таблица1");

                Таб.ВывестиСекцию("Секция_2");

                Если ВыпТО = 1 Тогда

                               //Если работы выполнял Сервисный центр

                               Таб.ВывестиСекцию("Секция_3");

                               ДЗ = СоздатьОбъект("Документ");

                               ДЗ.ВыбратьПодчиненныеДокументы(,,ТекущийДокумент());

                               Если ДЗ.ПолучитьДокумент() = 1 Тогда  

                                               ДЗ.ВыбратьСтроки();

                                               Пока ДЗ.ПолучитьСтроку() = 1 Цикл

                                                               Ном1 = ДЗ.НомерСтроки;

                                                               ЗИП = ДЗ.ЗИП;

                                                               ЕдИзм = ДЗ.ЕдИзм;

                                                               Количество = ДЗ.Количество;

                                                               Таб.ВывестиСекцию("Секция_4");

                                               КонецЦикла;

                               КонецЕсли;

                               Таб.ВывестиСекцию("Секция_5");

                               ВыбратьСтроки();

                               Пока ПолучитьСтроку() = 1 Цикл

                                               Ном2 = НомерСтроки;

                                               Таб.ВывестиСекцию("Секция_6");

                               КонецЦикла;     

                               Таб.ВывестиСекцию("Секция_7");

                ИначеЕсли ВыпТО = 2 Тогда

                               //Если работы выполняла сторонняя ремонтная фирма

                               Таб.ВывестиСекцию("Секция_8");

                КонецЕсли;

                Таб.Опции(0,0,0,0);

                Таб.ТолькоПросмотр(1);

                Таб.Показать("Квитанция на техническое обслуживание","");

КонецПроцедуры

//*****************************************************

Процедура ВводНового()

                Автор=глАвтор;               

КонецПроцедуры

 

 

 

 


Листинг Документ.Заявка

 

//*********************************************************

//

//Проверка на прохождение ремонта и его статус

Процедура ПроверкаСН()

                Если (СерийныйНомер.СтатусРемонта=Перечисление.СтатусыРемонта.НаТО) Тогда

                               Предупреждение("Оборуудование  с серийным номером "+СерийныйНомер+"

                                                                                              |уже находиться на ТО!");

    ИначеЕсли (СерийныйНомер.СтатусРемонта=Перечисление.СтатусыРемонта.НаРемонте) Тогда

                               Предупреждение("Оборуудование  с серийным номером "+СерийныйНомер+"

                                                                                              |уже находиться в ремонте!");

                КонецЕсли;

                Если СерийныйНомер.СтатусОборудования<>Перечисление.СтатусыОборудования.Продано Тогда

                               Если Вопрос("Оборудование не продано. Оно находится на складе. Продолжить?",4)<>6 Тогда

                                               СерийныйНомер=0;

                                               Возврат;

                               КОнецЕсли;

                КонецЕсли;

                Клиент=СерийныйНомер.Клиент;

                ОборудованиеСтр = СокрЛП(Строка(СерийныйНомер.ОборудованиеКр))+" "+СокрЛП(Строка(СерийныйНомер.Модель));

                Артикул = Строка(СерийныйНомер.Артикул);

КонецПроцедуры

//************************************************************

//Проверка возможнности сохранения документа

Процедура ПоКнОк()

                Если Проведен() = 0 Тогда

                               Если ПустоеЗначение(Клиент) = 1 Тогда

                                               Предупреждение("Не выбран клиент!");

                                   Возврат;

                               КонецЕсли;

                               Если ПустоеЗначение(СерийныйНомер) = 1 Тогда

                                               Предупреждение("Не выбрано оборудование!");

                                   Возврат;

                               КонецЕсли;

                               Если ПустоеЗначение(Причина) = 1 Тогда

                                               Предупреждение("Не указана причина обращения!");

                                   Возврат;

                               КонецЕсли;

                               //Запись и проведение документа

                               Записать();

                               Провести();

                КонецЕсли;

                Форма.Закрыть(0);

КонецПроцедуры            

//************************************************************

//Ввод нового прихода

Процедура ВводНового()

                Автор=глАвтор;

                ТипОбслуживания=1;

КонецПроцедуры

//************************************************************//

//Открытие бланка приема на техническое обслуживание

Процедура ПриОткрытии()

    Если Проведен() = 1 Тогда

                               Форма.ТолькоПросмотр(1);

                Иначе   

                               Форма.ТолькоПросмотр(0);

                КонецЕсли;

                ПриЗаписиПерепроводить(0);

КонецПроцедуры

//***************************************************************

//Печать талона

Процедура ПоКнТалон()

                //Вывод на печать

                Таб = СоздатьОбъект("Таблица");

                Таб.ИсходнаяТаблица("Таблица1");

                Таб.ВывестиСекцию("Секция_2");

                Таб.Опции(0,0,0,0);

                Таб.ТолькоПросмотр(1);

                Таб.Показать("Талон на техническое обслуживание","");

КонецПроцедуры